
HOW TO: Use Addresses from an Excel 2002 Worksheet to 

Create Labels in Word 2002 

This article was previously published under Q318117 

IN THIS TASK 

SUMMARY 
You can use the Mail Merge feature in Word to create and print labels for a mass mailing by using data from an Excel 

Worksheet. This article contains instructions that you can use to create such a list. 

 

When you use the Word 2002 mail merge feature, Word merges a "main document" with a "recipient list" to generate 

a set of "output documents": 
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Step 1: Set Up the Excel Data File 

Before you proceed with the Mail Merge Wizard, make sure that your Excel worksheet is well structured for this 

purpose. Note the following requirements for the data table: 

To arrange your Excel data file, follow these steps: 
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� The main document contains the basic text that is the same in all of the output documents. It may contain a 

letterhead, text, and instructions in "merge fields" for inserting text (such as recipient names and addresses) 

that varies from one output document to another.

� The recipient list is a database-for example, a Microsoft Access 2002 database file or a Microsoft Excel 2002 

workbook-that contains the data that is to be merged into the output documents. This database is typically a 

list of names, addresses, and phone numbers.

� The output documents are the result of the mail merge. The text in an output document can be the same in all 

output documents, but you can apply formatting to specific documents. 

� The first row should contain field names for each column. For example, Title, Salutation, First Name, Middle 

Name, Last Name, Address1, and Address2. 

� Each field name must be unique. 

� Each row must provide information about a particular item. In a mailing list, for example, each row may 

include information about a particular recipient. 

� The table must not have blank rows. 
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For additional information about how to create a mail-merge address list, click the article number below to view the 

article in the Microsoft Knowledge Base: 

294688 HOW TO: Design and Set Up a Mail Merge Address List in Word 2002  
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Step 2: Set Up the Main Document 

1. Create your Excel data file, and arrange it by using the fields that you want to use for your label, as shown in 

the following sample data file:  

 

 

 

Last 

Name

First 

Name Title Address City

Postal 

Code Country

Davolio Nancy Sales 

Representative

1234 Main St. 

Apt. 2A

Seattle 14222 USA

Fuller Andrew Vice President, 
Sales

1235 Main St. Tacoma 14222 USA

Leverling Janet Sales 
Representative

1235 Elm St. Kirkland 14222 USA

Peacock Margaret Sales 

Representative

1236 Main St. Redmond 14222 USA

Buchanan Steven Sales Manager 1237 Main St London SW2 8MR UK

Suyama Michael Sales 
Representative

1238 Elm St. London EC3 7HR UK

King Robert Sales 
Representative

1239 Main St. London RK2 9NP UK

Callahan Laura Inside Sales 

Coordinator

1230 Elm St. Seattle 14222 USA

Dodsworth Anne Sales 
Representative

1231 Elm St. London WG2 7LT UK

2. After you create your Excel data file, save it, and then close the data file.

1. Start Microsoft Word 2002, point to Letters and Mailings on the Tools menu, and then click Mail Merge 

Wizard. 

2. Under Select document type, click Labels. 

 

The active document becomes the main document (the document that contains the text and graphics that are 

the same for each version of the merged document, for example, the return address or salutation in a form 

letter).

3. Click Next: Starting document.  

 

NOTE: If you are familiar with the mail merge feature or you prefer to work without the wizard, you can use 

the Mail Merge toolbar.

4. Do one of the following: 

� Create a new sheet of labels: 

a. Click Change document layout. 

b. Click Label options. 

c. In the Label Options dialog box, select the options that you want, such as the label type and 

size, and then click OK. 
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Step 3: Specify the Microsoft Excel Data Source 
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Step 4: Select the Recipients 

 

For help with an option, click the question mark, and then click the option.

� Start with an existing sheet of labels: 

a. Click Start from existing document. 

b. In the Start from existing box, select the document that you want, and then click Open. 

c. If you do not see the document, click More files, and then click Open. In the Open dialog box, 

locate the document that you want, and then click Open.  

 

Microsoft Word displays the document in the document window. If you decide to use a different 

label document instead, Click Start from existing document, and then select a different 

document. If you want to change the layout, click Change document layout, and then click 

Label options. 

5. Click Next: Select recipients. 

1. Under Select recipients, click Use an existing list. 

2. Click Browse.

3. In the Select Data Source dialog box, locate and click the Excel worksheet that you want to use. 

 

By default, Word opens the My Data Sources folder. 

4. Click Open.

5. If your Excel worksheet has information on multiple tabs, you have to select the tab that contains the 

information that you want, and then click OK. All of the entries in the data source appear in the Mail Merge 

Recipients dialog box, where you can refine the list of recipients to include in the merge.

1. In the Mail Merge Recipients dialog box, select the recipients that you want to include. To do this, do any 

of the following: 

� Use the check boxes to designate recipients. 

 

This method is most useful if your list is short. Select the check boxes next to the recipients that you 

want to include, and clear the ones next to the recipients that you want to exclude. 

 

NOTE: If you know that you want to include most of the list in your merge, click Select All and then 

clear particular records. Similarly, if you want to include only a few records in the list, click Clear All, 

and then select the records that you want.

� Sort items in the list. 

 

This is useful if you want to see items in alphabetical or numeric order. Click the column heading of the 

item that you want to sort by. For example, if you want to display the list alphabetically by last name, 

click the Last Name column heading. 

� Filter items in the list. 

 

This is useful if the list contains records that you know that you do not want to see or include in the 

merge. After you have filtered the list, you can use the check boxes to include and exclude records as 

described in the previous section. To filter the list, follow these steps: 

a. Click the arrow next to the column heading of the item by which you want to filter.

b. Click any of the following: 
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Step 5: Arrange the Content of Your Labels 

To arrange the content of your labels, follow these steps. 

Insert Merge Fields 

Insert merge fields where you want to merge names, addresses, and other information such as a postal bar code. For 

example, insert the merge field "City" to have Word insert a city name, such as "Atlanta," that is stored in the City 

data field. To insert merge fields, follow these steps: 

NOTES: 

� (Blanks) displays all the records in which the corresponding field is blank. 

� (Nonblanks) displays all the records in which the corresponding field contains information. 

� If your data source contains records that share the same information, and there are ten or 

fewer unique values in the column, you can filter by specific information. For example, if 

there are multiple addresses that list Australia as the country/region, you can filter on 

Australia. 

� The Mail Merge Recipients dialog box displays only the designated records. To display all the records 

again, click (All). 

� For advanced sorting and filtering, click the arrow next to any column name, and then click 

(Advanced). Use the Filter Records tab and the Sort Records tab to set up the sorting or filtering 

query that you want. 

� If you have installed address validation software, you can click Validate in the Mail Merge Recipients 

dialog box to validate your recipients' addresses. 

2. :Click OK to return to the Mail Merge Wizard.  

 

Word will use the recipients that you designated for the merge. 

3. :Click Next: Arrange your labels. 

1. In the main document, click where you want to insert the field.

2. Insert any of the following: 

� Address block with name, address, and other information 

a. Click Address block. 

b. In the Insert Address Block dialog box, select the address elements that you want to include 

and the formats that you want, and then click OK. For help with an option, click the question 

mark, and then click the option. 

 

c. For help with an option, click the question mark, and then click the option.If the Match Fields 

dialog box appears, Word may not have been able to find some of the information it needs for 

the address block. Click the arrow next to (not available), and then select the field from your 

data source that corresponds to the field required for the mail merge. 

� Greeting line 

a. Click Greeting line. 

b. Select the greeting line format, which includes the salutation, name format, and following 

punctuation. 

c. Select the text that you want to appear in cases where Word cannot interpret the recipient's 

name, for example, when the data source contains no first or last name for a recipient, but only 

a company name.

d. Click OK. 
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NOTE: You can also use the Mail Merge toolbar to insert merge fields, work with your mail merge main 

document, or to run a mail merge. To display the Mail Merge toolbar, point to Letters And Mailings on the 

Tools menu, and then click Show Mail Merge Toolbar. The Mail Merge toolbar provides additional 

commands not included in the Mail Merge wizard task panes. For example, you can use the Insert Word Field 

drop-down menu on the Mail Merge toolbar to insert Word fields for controlling the merge process (for 

example, an IF field that inserts text only if a particular merge field has a specified value). Or, you can click 

Check For Errors to have Word run the mail merge and report any errors contained in the main document. 

e. If the Match Fields dialog box appears, Word may not have been able to find some of the 

information it needs for the greeting line. Click the arrow next to (not available), and then select 

the field from your data source that corresponds to the field required for the mail merge.

� Other fields of information 

a. Click More items. 

b. Do one of the following: 

� To select from address fields that will automatically map to corresponding fields in your 

data source, even if the data source's fields do not have the same name as your fields, 

click Address Fields. 

� To select from fields that always take data directly from a column in a database, click 

Database Fields. 

c. In the Fields box, click the field that you want. 

d. Click Insert, and then click Close. 

e. If the Match Fields dialog box appears, Word may not have been able to find some of the 

information it needs to insert the field. Click the arrow next to (not available), and then select 

the field from your data source that corresponds to the field required for the mail merge. 

 

NOTE: If you insert a field from the Database Fields list, and then later switch to a data source 

that does not have a column with the same name, Word will not be able to insert that field 

information into the merged document.

� Electronic postage To add electronic postage, you must first install an electronic postage program, such 

as one that you purchased from a service on the World Wide Web. To use electronic postage, follow 

these steps: 

a. Click Electronic postage.  

 

If you do not have an electronic postage program installed, Word prompts you to install one and 

offers to connect to the following Microsoft Web site:Microsoft Office Web

b. Insert the postage according to the program's instructions. 

� To add electronic postage, you must first install an electronic postage program, such as one that you 

purchased from a service on the World Wide Web. To use electronic postage, follow these steps: Postal 

bar code You must select a label or envelope type that supports the POSTNET bar code. To use the 

Postal bar code, follow these steps: 

a. Click Postal bar code.

b. In the Insert Postal Bar Code dialog box, select the appropriate address fields.  

 

NOTE: The Postal bar code option appears only if you are using the U.S. language version of 

Word.

c. Repeat steps a and b for all of the fields that you want to insert.NOTES: 

� You cannot type merge field characters (" ") or insert them by using the Symbol command 

on the Insert menu. 

� If the merge fields appear inside braces, such as { MERGEFIELD City }, then Word is 

displaying field codes instead of field results. This does not affect the merge, but if you 

want to display the results instead, right-click the field code, and then click Toggle Field 

Codes on the shortcut menu.
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Change the Format of the Merged Data 

To format merged data, you must format the merge fields in the main document. Do not format the data in the data 

source, because its formatting is not retained when you merge the data into the document. To change the format of 

the merged data, follow these steps: 

Format by Using Field Codes 

To control other aspects of formatting, press ALT+F9 to display field codes, and then add switches to the merge fields.

When you work with fields, a switch is special instruction that causes a specific action to occur. Generally, you add a 

switch to a field to modify a result. 

 

For example: 

To copy the format and layout of the first label to all the other labels on the page, click Update all labels.  

 

For example, in the sample database shown earlier in this article, if you insert only the AddressBlock field, and then 

click Update all labels, the page should appear similar to the following:  

 

<<AddressBlock>><<Next Record>><<AddressBlock>>  

 

<<Next Record>><<AddressBlock>><<Next Record>><<AddressBlock>>  
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Step 6: Save the Document 

After you have completed the main document and inserted all of the merge fields, save the document before you 

proceed. 
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Step 7: Preview the Labels and Fine-Tune the Recipient List 

When the wizard displays the Step 5 Mail Merge task pane, it replaces each of the merge fields in the main document 

with the actual text from the first entry of the recipient list, so that you can see how your first output document will 

look. 

 

For example, if you continue to use the sample database shown earlier, after you click Next: Preview your labels, 

the first page should appear similar to the following: 

1. In the main document, select the field containing the information that you want to format, including the 

merge field characters ("" "") that enclose it.

2. On the Format menu, click Font, and then select the options that you want. 

1. To display the number "34987.89" as "$34,987.89," add the Numeric Picture switch (\#). 

2. To print client names in uppercase letters, add the Format switch (\*). 

3. To make sure that the merged information has the same font and point size that you apply to the merge field, 

add the \* Charformat switch. 

1. Click Save As on the File menu. 

2. Name the document, and then click Save.

3. Click Next: Preview your labels. 

Vice President, Sales Andrew Fuller     Sales Representative Anne Dodsworth 

1235 Main St                            1231 Elm St. 

Tacoma                                  London 

 

 

Sales Representative Janet Leverling     Inside Sales Coordinator Laura Callahan 
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To preview additional entries, do either of the following: 

To fine-tune the recipient list, for example, to exclude a recipient: 
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Step 8: Complete the Merge 

To complete the merge, do any of the following: 

Personalize Individual Labels 

To personalize individual labels, complete the merge, and then edit the information that you want in the resulting 

merged document. 

back to the top 

Print the Sheet of Labels 

To print the sheet of labels, do either of the following: 

1235 Elm St.                             1230 Elm St. 

Kirkland                                 Seattle 

    

� To preview the items in order, click the left or right arrow buttons.  

 

Each record is previewed in the first label on the sheet. 

� To locate and preview a specific item, click Find a recipient, and then enter the search criteria in the Find 

Entry dialog box. 

1. Click Edit recipient list, and then make your changes in the Mail Merge Recipients dialog box. 

2. Click Next: Complete the merge. 

1. Click Edit individual labels. 

2. In the Merge to New Document dialog box, select the records that you want to merge.

3. Click OK. 

 

Word creates and opens a new merged document. Your main document also remains open, and you can 

switch back to it if you want to make a change to all the items. 

4. Scroll to the information that you want to edit, and make your changes.

5. Print or save the document just as you would any regular document.

� If you personalized the items and the merged document is active: 

1. On the File menu, click Print. 

2. Select the options that you want. 

� If you want to print directly from the Mail Merge Wizard: 

1. In Step 6 of the Mail Merge Wizard (Complete the merge), click Print. 

2. In the Merge to Printer dialog box, do one of the following, and then click OK: 

� To print all the documents, click All. 

� To print the document that you see in the document window, click Current record.

� To print a range of documents, click From, and then type the record numbers in the From and 

To boxes. 

3. In the Print dialog box, select the options that you want. 
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Save the Sheet of Labels for Later Use 

If you want to edit merged labels or save them for later use, you can collect them into a single document. 
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REFERENCES 

For more information about IF fields, click Microsoft Word Help on the Help menu, type Field Codes: IF field in 

the Office Assistant or the Answer Wizard, and then click Search to view the topics returned. 

 

For more information about MERGESEQ fields, click Microsoft Word Help on the Help menu, type Field Codes: 

MERGESEQ field in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned. 

 

For more information about SET field, click Microsoft Word Help on the Help menu, type Field Codes: SET field in 

the Office Assistant or the Answer Wizard, and then click Search to view the topics returned. 

 

For more information about general field formatting switches, click Microsoft Word Help on the Help menu, type 

general switches in the Office Assistant or the Answer Wizard, and then click Search to view the topic. 

 

For additional information about mail merge, click the article numbers below to view the articles in the Microsoft 

Knowledge Base: 

294691 WD2002: Mail Merge Basics - The Process Explained  

294686 HOW TO: Use Mail Merge to Create a List Sorted by Category in Word 2002  

290408 WD2002: Frequently Asked Questions About Mail Merge  

294688 HOW TO: Design and Set Up a Mail Merge Address List in Word 2002  

294693 WD2002: How to Use Mail Merge to Create a Directory  

294683 HOW TO: Use Mail Merge to Create Form Letters in Word 2002  
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APPLIES TO 

1. Click Edit individual labels. 

2. In the Merge to a New Document dialog box, do one of the following, and then click OK: 

� To merge all the documents, click All. 

� To merge only the document that you see in the document window, click Current record. 

� To merge a range of documents, click From, and then type the record numbers in the From and To 

boxes.

3. Word opens a single new document that contains all the individual labels. You can then save the document for 

later use, just as you would any regular document.

� Microsoft Word 2002 Standard Edition

� Microsoft Excel 2002 Standard Edition
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